Back to overview
Resolved

Server Upgrade

Aug 14, 2026 at 3:34pm UTC  –  Aug 14, 2026 at 3:40pm UTC
Affected services
Vaizy Website

Resolved
Aug 14, 2026 at 3:40pm UTC

Maintenance ended

Created
Aug 14, 2026 at 3:34pm UTC

Marketing is currently disabled, we'll be back shortly